Hyundai Kia Forums

Hyundai Kia Forums (https://hyundaikiaforums.com/hyundai-kia-forums/index.php)
-   Kia Optima Forum (https://hyundaikiaforums.com/hyundai-kia-forums/forumdisplay.php?f=20)
-   -   2003 Kia Optima ISSUES!! (https://hyundaikiaforums.com/hyundai-kia-forums/showthread.php?t=22689)

Nickd00 04-05-2016 01:26 AM

2003 Kia Optima ISSUES!!
 
Hi guys, im in great need of some advice! Im new here, so id like to thank everyone in advance. I have a 2003 Optima LX 2.4 4 cyl & auto trans with 130k miles. Car jus died while driving, then would turn over but not crank. Sprayed with starting fluid an fired right up, repaced pump and no change. Still wont crank, i can here and feel the new pump running. Also took fuel line loose under throttle body an i get good fuel pressure when motor is being cranked over but none when key is turned on. Code reader has p0335 crankshaft position sensor. Any ideas??? I've owned car for about a year, had 104k when i got it. Im not sure of maintenance or if timing belt has ever been replaced. Would it start with fluid if crank sensor is bad? Is there anything else i can try to diagnose my issue? Thanks


All times are GMT -4. The time now is 04:35 AM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
hyundaikiaforums.com recognizes that "Hyundai", "Kia", it's logos and various model names and numbers are registered trademarks of the Hyundai Motor Company. These terms are used for identification purposes only. hyundaikiaforums.com is not affiliated in any way with the Hyundai Motor Company, Hyundai, Kia or any other company listed herein. All information on this site is the opinion of its members and not the opinion of the site itself. ©2017 hyundaikiaforums.com. All rights reserved.